Panoply Instructions for WRFV4

Updated: February 2023

Preliminaries

e Choose the appropriate version of Panoply for your OS; download and
install by following the instructions:
https://www.giss.nasa.gov/tools/panoply/download/

o For Mac OS computers with Intel hardware, choose “use native
filechooser”

o Ifyou are running a newer Mac OS computer with Apple M1/M2
chips, choose “requires M1/M2 Mac with ARM64 Java”

e Note that you may need to have Java 11 JRE/JDK installed for Panoply to
work
o However, as of this document, Panoply 5.2.3 is able to run on a
Macbook Pro 2016, running macOS Monterrey and Java 8
o The newest versions of Java can be found and downloaded from here:
https://www.oracle.com/ca-en/java/technologies/downloads/#javal9

o ***Panoply only recognizes files that are suffixed with expected file
formats, i.e. NetCDF files suffixed with .nc
o By default, wrfout* files are NOT suffixed with .nc; consequently,
Panoply won’t be able to open them without renaming
o Rename all wrfout files by adding “.nc” at the end, e.g.

myv wrfout_d01_2018-12-20_23:00:00 wrfout_d01_2018-12-20_23:00:00.nc


https://www.giss.nasa.gov/tools/panoply/download/
https://www.oracle.com/ca-en/java/technologies/downloads/#java19
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Name Long Name Type
¥ [“) wrfout_d01_2018-12-20_23:00:00.nc OUTPUT FROM WRF V4.1.3 MODEL Local File File "wrfout_d01_201!
© ACGRDFLX ACGRDFLX Geo2D
@ ACHFX ACHFX Geo2D File type: NetCDF-3/CDM
@ ACLHF ACLHF Geo2D -
© ACLWDNB ACLWDNE GeozD netcdf file:/Users/tcl
© ACLWDNBC ACLWDNBC Geo2D dimensions:
@ ACLWDNT ACLWDNT Geo2D Time = UNLIMITED;
© ACLWDNTC ACLWDNTC Geo2D DateStrlen = 19;
© ACLWUPB ACLWUPB Geo2D west_east = 120;
© ACLWUPBC ACLWUPBC Geo2D south_north = 120
@ ACLWUPT ACLWUPT Geo2D CPEELLED & ¢p
© ACLWUPTC ACLWUPTC Geo2D botton_top_stag =
soil_layers_stag :
@ ACSNOM ACSNOM Geo2D west_east_stag = -
@ ACSWDNB ACSWDNB Geo2D south_north_stag :
@ ACSWDNBC ACSWDNEC Geo2D seed_dim_stag = 3
@ ACSWDNT ACSWDNT Geo2D variables:
@ ACSWDNTC ACSWDNTC Geo2D char Times (Time=1
@ ACSWUPB ACSWUPB Geo2D .
© ACSWUPEC ACSWUPBC Geo2D float XLAT(Tine=1
© ACSWUPT ACSWUPT Geo2D e s )
@ ACSWUPTC ACSWUPTC Geo2D :description = '
© ALBBCK ALBBCK Geo2D iunits = "degre:
@ ALBEDO ALBEDO Geo2D :stagger = "";
@ CIF CIF iD :coordinates = '
Q ClH C1H 1D
o C2F C2F 1D float XLONG(Time=
@ C2H C2H 1D :FieldType = 104‘
o 1 Ity
mc5h (L] £ :units = "degre:
i o 0 e
tcoordinates = '
© CANWAT CANWAT Geo2D
@ CF1 CF1 — float LU_INDEX(Til
@ CF2 CF2 — :FieldType = 16
& CF3 CF3 _ :Memor)_rurqer ="'
© CFN CFN _ :des_cr1p‘cl}2n ="
@ CFN1 CFN1 - E::;;;e? -
@ CLAT CLAT Geo2D GRS = |
Show: All variables

e Open up a wrfout file by running Panoply, and choosing a wrfout file to
load; alternatively, once Panoply is opened, you can select your file by
choosing File > Open (top left)

e You should see the listing of raw variable names associated with that file in
the left panel, and a description of the netcdf file and variables on the right
(i.e. what you would get by running ncdump on the file)
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Name Long Name Type
T T Geo2D Variable "T2"
@ TOO TOO —
QT2 T2 Geo2D In file "wrfout_d01_20:
@ TH2 TH2 Geo2D -
© THIS_IS_AN_IDEAL_RUN THIS IS AN IDEAL RUN = RS VAR, o
@ THM THM Geo2D AFEENSTE = 10?:

:MemoryOrder = "X
@ Time synthesized time coordinate from Times(time) - idescription = T
@ Times Times — runits = "K":
@ TISO TISO — :stagger =
@ TKE_PBL TKE PBL Geo2D :coordinates = "X
Q TLP TLP — S ————
@ TMN TMN
Q TsK TsK More than one type of plot can be created from the variable 'T2'. What type would you like to create?
@ TSK_FORCE TSK FORCE
© TSK_FORCE_TEND TSK FORCE TEND © Georeferenced Longitude-Latitude color contour plot
@ TSLB TSLB Georeferenced  Zonal Average line plot
Qu u
@ u10 ) Color contour plot using south_north for X axis and west_east for Y axis
© UDROFF UDROFF Line plot using south_north for the horizontal axis
@ UsT usT
Qv v Cancel  (JEREEEEN)
Q@ vio V10
9 VAR VAR
@ VAR_SSO VAR S50 eo
@ VEGFRA VEGFRA Geo2D
QW W Geo2D
@ x synthesized GeoX coordinate from DX attribute 1D
@ x_stag synthesized GeoX coordinate from DX attribute 1D
@ XICEM XICEM Geo2D
@ XLAND XLAND Geo2D
@ XLAT XLAT Geo2D
@ XLAT_U XLAT U Geo2D
@ XLAT_V XLAT V Geo2D
@ XLONG XLONG Geo2D
@ XLONG_U XLONG U Geo2D
@ XLONG_V XLONG V Geo2D
@ XTIME XTIME —
Show: Allvariables ]

e Scroll down, and choose “T2” —> select the first option “Georeferenced
Longitude-Latitude color contour plot”, and select Create
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Plot Controls

Name
T
@ T00
QT2
O TH2

© THIS_IS_AN_IDEAL_RUN

© THM

@ Time

@ Times

@ TIso

© TKE_PBL
o TP

@ TLP_STRAT
@ TMN

@ TSK

© TSK_FORCE
© TSK_FORCE_TEND
© TSLB
Qu

@ u10

© UDROFF
@ usT

Qv

@ vio

@ VAR

@ VAR_SSO
© VEGFRA
ow

@ x

@ x_stag

@ XICEM

@ XLAND
@ XLAT

@ XLAT_U
@ XLAT_V
© XLONG
@ XLONG_U
@ XLONG_V
@ XTIME

+ T2 in wrfout_d01_2018-12-20_23:00:00 T2
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Show: Allvariables 2] |

e You should now see your T2 color-filled contour plot appear, with the
polar-stereographic domain projected onto an equirectangular map (hence
the “tilt” of your domain)

e At the top, select “Window > Plot Controls” to enable configurations for the

plot



Plot Controls

Show:  Grid

Spacing: 5.0 B ewx 5.0 B °N-s P T2
Offset parallels from Equator

stroke:  Solid B .Color: EEEEE @ ,Weight: 50 % B

Labels;:  None ,Size: 6.5

Grid labels are only available for cylindric projections

vz
@ TH2 E
© THIS_IS_AN_IDEAL_RUN
© THM

@ Time

@ Times

@ TISO

© TKE_PBL

Qe B
@ TLP_STRAT

@ TMN

@ TSK

© TSK_FORCE

© TSK_FORCE_TEND
@ TSLB

Qou

@ u10

@ UDROFF

@ usT

Qv

@ v10 —
@ VAR —
@ VAR_SSO VAR | |
@ VEGFRA VEGI
ow w
o x syntf
© x_stag syn ‘ L N N L >
@ XICEM XICE 241.5 252.9 264.3 275.7 287.1 298.5
SJCAND X3 Data Min = 241.5, Max = 298.5

Q XLAT XLAT -2 .

@ XLAT_U
@ XLAT_V
@ XLONG

T2 (K)

e With Plot Controls, you can configure what your plot looks like

e The “Show” dropdown menu allows you to access different portions of the
configuration

e The figure above shows the effects of selecting “Grid” and changing the
“Spacing” of the latitude and longitude grid lines
o Note that the plotted base projection was changed earlier (not shown)
due to selecting the Stereographic projection under “Map Projection”
o The next page shows the effects of changing the Map Projection and
the zoom



Plot Controls

Show: Map Projection Plot

Projection: Stereographic

Center on: Lon. -120 °E Lat. 49

EdgeAngle:  10.0 °(<150.0° , @ Fill corners
oT
@ T00
QT2
@ TH2
© THIS_IS_AN_IDEAL_RUN
© THM
@ Time
@ Times
@ TISO
© TKE_PBL
Q@ Te i
@ TLP_STRAT
© TMN
@ TSK
© TSK_FORCE
© TSK_FORCE_TEND
@ TSLB
Qu
Q u1o
© UDROFF
Q@ usT
oV
@ V10
@ VAR
@ VAR_SSO
© VEGFRA
ow w
@x
@ x_stag syl
@ XICEM
@ XLAND X
@ XLAT
@ XLAT_U
© XLAT_V
@ XLONG

- Ty
T2 (K)

< >

241.5 252.9 264.3 275.7 287.1 298.5

Data Min = 241.5, Max = 298.5

e Under Map Projection in the “Show” dropdown, you can change the
Projection to Stereographic, and also define the center latitude and longitude
of the map

e “Edge Angle” determines the zoom of the map...the lower the number, the
higher the zoom



Plot Controls

Show: Overlays 8

¥ Overlay 1
Name: MWDB_Coasts_NA_l.cnob

Color: mmmmm @  Weight: 75

Style:  Solid 8
¥ Overlay 2
Name: None

Color: [ @  Weight: 50
Style:  Solid 8

¥ Overlay 3

Name:  None

Color: mmmmm @  Weight: 50

Style:  Solid

@ TSK

© TSK_FORCE
@ TSK_FORCE_TEND
@ TSLB

Qu

@ ulo

@ UDROFF

@ usT

Qv

@ vio

@ VAR

@ VAR_SSO
@ VEGFRA

@ XLONG

Plot | Array 1

T2 in wrfout_d01_2018-12-20_23:00:00

i

s
T2 (K)

2415 252.9 264.3 275.7 287.1 298.5

Data Min = 241.5, Max = 298.5

e You can add political boundaries and higher-res coastlines in the “Overlays”
option of the “Show” dropdown

e [n “Overlay 17, in the “Name” dropdown, select
“MWDB_Coasts NA 1.cnob” —> this will produce the North American
national and sub-national boundaries, as well as a better coastline



Plot Controls

Show: Scale ]
Range:  Min.: -10 , Max.: 100 FittoData T2
Units: Scalar B of Celsius % Scaling:10A 0
Colorbar: Color Table: [ panoply.act B —  Reversecolors
Fill Color: T3
|
Location: ~ Below Plot —Length: 60 %
Qutliers on:  Both Ends @ ,Shape: Triangle ,Gap: Thin @
Border Weight: 100
Ticks:  Divisions, Major: 5, Minor: 2
Labels: Format: %1f @ —Size: 110 B .
Major Tick Length:  Short [
Caption: @ Default  Custom: SCALECAPTION —Size: 140 @ - = P
Location: Above Colorbar s
- +A
@ TSK_FORCE TSK
@ TSK_FORCE_TEND TSK .
QTSI TSLB
QU u
Q ulo u1o ‘
© UDROFF UDR Aw
Q usT usT .
o : ‘ .
Qv10 V10 . %
Q VAR VAR
@ VAR_SSO VAR
@ VECFRA VEG -
ow w .
ox T2 (Celsius)
syntl
0 x sty ol 4EE @ |
@ XICEM XICE| -10.0 -6.0 -2.0 2.0 6.0 10.0
© XLAND XLAN )
A VI AT | Data Min = -31.6, Max = 25.4

e To change the colormap and units of the variables, go to “Scale” in the
“Show” dropdown

e Here, you can change the range of the data, as well as the units (e.g. click on
the “K” next to “Units” and change to “Celsius”)
o In regards to the data range, “Fit to Data” will automatically adjust the
range to the minimum and maximum of the variable

e Note on animations: unlike IDV, Panoply will only support animation
creation if multiple time steps are contained within a single netcdf file
o To create an animation, in the top left, select File > Export Animation

o The animation generation will use the configuration you provided
when customizing your individual plots for all of the frames (i.e.
projection, zoom, colormap, etc.)




¥ Places
= My Places
B3 sightseeing Tour
Make sure 3D Buildings
layer is checked
~ @< Temporary Places
®<S 00.kmz
@& 12
® & Colorbar

EI | ¥

¥ Layers
© % Primary Database
& Announcements
F Borders and Labels
Places
= Photos ‘
" Roads
@A 3D Buildings
i} Weather
¥ Gallery
[J More
@ Terrain

| 2
fimagery Date:12/1/201 5oy o aNa560.5

e You can also export your image as a .kmz (File > Export KMZ), and open
with Google Earth...see what you get!



Plot Combinations and Vectors

pn G n b
:reate Plot  Combine Plot @ Remove  Remove All Hide Infa
u10
Datasets = Catalogs  Bookmarks
Name Long Name Type
W inv ITHM LeoZv
. [ =
© Time synthesized time coordinate from Ti... - Variable "v10" 5 % j iy i h%
© Times Times - In file "wrfout_d01_2018-12-20_23:00:00.n¢" Hméééﬁm;;&b El g
:IEEOPBL IESPBL G 7ZD float V10(Time=1, south_north=128, west_ea = C = ?—\v )Ij = (V<&
€0 = = >
| t i U ' _ Jor
o1 TLp - :FieldType = 104; // int k\"\ \Uj 23 di;/?“
@ TLP_STRAT TLP STRAT - iMemoryOrder = "XY "; ?:;,, N S Y
© TMN TN Geo2D :description = "V at 18 M"; > ; 5‘:9‘ |
0 TSk 75K Geo2D :”;'lts =Ll 7 AN “) ’ q .
istagger = "'} “*
© TSK_FORCE TSK FORCE - scoordinates = "XLONG XLAT XTIME"; A C PN
© TSK_FORCE_TEND TSK FORCE TEND A 1 -
@ TSLB TSLB £0 el
QU v Combine Plot M \\r-*’\)
Q10 u10 i -rm7 X
© UDROFF UDROFF In which existing plot should | combine the variable?
Q usT usT -/
oV v U10 in wrfout_d01_2018-12-20_23:00:00
QVio V10 C
© VAR VAR Cancel - J/
© VAR_SSO VAR S50 4
© VEGFRA VEGFRA Hi
ow w

e To plot vectors of U10 and V10, first plot U10 as normal (like plotting T2)

e Then, select V10, but do not click “Create Plot” —> instead, select
“Combine Plot”, and choose the shown option to merge the plot with U10
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U10 in wrfout_d01_2018-12-20_23:0

Plot Controls

Show -~ ] Plot = Array 1 = Array 2
Array 1 Only ‘ ‘
Array 2 Only Rel
Array 2 - Array 1 G irterpolate U 10
Array 1 + Array 2 —
ey L a2 me) 1 of1= 2018-12-2023:00:00 Typ
Array 1/ Array 2 20:
x:?:vzlf—A;rr?:ylﬁ / Array 2 _< =
(Array 2 = Array 1) / Array 1 me): 1 of 1= 2018-12-20 23:00:00 i L—"
Average - (? <
©@ TKE  Merge ) Geo I
O TLF Vector Magnitude E |
@ TLP_STRAT TLP STRAT - rac
@ TMN TMN Geoi Ay
@ TSK TSK Geoi 7
© TSK_FORCE TSK FORCE 4 N
@ TSK_FORCE_TEND TSK FORCE TEND - 3
o TsL8 TSL8 Geol g y
Qu u Geoi \\gj \\ \\,_-'\.}
Qu10 u1o Geol s o
@ UDROFF UDROFF Geoi v \
@ usT usT Geo
ov v Geo 7 J ;’{
o V1o V10 Geol /l
© VAR VAR Gea 5 ==
© VAR S50 VAR SSO Geo i
© VEGFRA VEGFRA Geo ‘e’i
ow w Ceoi
@ x synthesized GeoX coordinate from D... 1C =
@ x_stag synthesized GeoX coordinate from D... 1C | a | e
@ XICEM XICEM Geoi === =
@ XLAND XLAND Geoj g
@ XLAT XLAT Geo
@ XLAT U XLAT U Geo:
@ XLAT.V XLAT V Geo U10 - V10 (m s-1)
9 XLONG XLONG Geol 4JEEET W0
© XLONG_U XLONG U Geoi -10.8 -4.4 2.0 8.5
A YINONC VIAKIC A rant

e By default, combining plots will subtract the two fields; instead, we want to
compute vectors
o In the “Show” dropdown of Plot Controls, select “Arrays”
o Then under the “Plot” dropdown, choose “Vector Magnitude”
o This will now change the plot to show wind vectors, as well as wind
speed as a color-filled contour



Plot Controls

Plot
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U10 in wrfout_d01_2018-12-20_23:00:00
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é Show: Vectors ]

ate Rel

| Style:  Arrow B Spacing: 50 %,

1”_ Color: NN ,Weight: 75 %
\ Array 1 values are positive  East a fisame u:‘g
{ Array 2 values are positive  North B roordinate from Ti... —|
: Reference Value: 10 .
{ Scale Sample: Visible Geol
QTP TP —
@ TLP_STRAT TLP STRAT —|
@ TMN TMN Geoi
Q@ TSK TSK Geo:
© TSK_FORCE TSK FORCE -
© TSK_FORCE_TEND TSK FORCE TEND -
@ TSLB TSL8 Geo:
Qu u Geo:
QU1 u1o Geo,
© UDROFF UDROFF Geo
@ UsT ust Geo:
QV v Geo:
Q10 V10 Geol
@ VAR VAR Geo:
@ VAR_SSO VAR 550 Geo:
© VEGFRA VEGFRA Geo;
ow w Geol
@ x synthesized GeoX coordinate from D... 10
@ x_stag synthesized GeoX coordinate from D... 1c
@ XICEM XICEM Geo;
@ XLAND XLAND Geo:
Q XLAT XLAT Geo:
@ XLAT_U XLAT U Geo:
@ XLAT_V XLAT V Geo:
© XLONG XLONG Geo,
@ XLONG_U XLONG U Geo
@ XLONG_V XLONG V Geod
© XTIME XTIME —

<EET

-10.8

Sqrt[(U10)* + (V10)3

-4.4

2.0 8.5 14.9

Data Min = 0.0, Max = 25.4

e The plot above was zoomed into the domain by holding right click on the
mouse, and dragging it over the area of interest

e Under “Plot Controls” — “Show” —> “Vectors”, you can configure the

vectors as you please

o Try reducing “Spacing” to increase the density of plotted vectors, and
“Reference Value” to change the base length of the vectors
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Create Plot Combine Plot Open Remove  Remove All Hide Info

Datasets Catalogs Bookmarks

Name Long Name Type
© THM THM Geo2D Variable "U"
Q@ Time synthesized time coordinate from Ti... —
@ Times Times — In file "wrfout_d01_2018-12-20_23:00:00.nc"
Q TIsO TISO — )
© TKE_PBL TKE PBL Geo2D float' U(Time=1, bottom_?op=40, south_north
oTP TLP = enorybrder < mYzh;
:I;PFGSTRAT TLP STRAT . _2 :descr{ption = “x-wind component";

TMN e02D runits = "m s-1";
Q@ TSK TSK Geo2D :stagger = "X"; '
@ TSK_FORCE Al scoordinatac = "XLONG_U XLAT_U XTIME";
© TSK_FORCE_TEND Create Plot
© TSLB
Qu More than one type of plot can be created from the variable 'U'. What type would you like to create?
9 u1o Georeferenced Longitude-Latitude color contour plot
© UDROFF
@ UsT Georeferenced  Zonal Average line plot
: xlo © Color contour plot using  south_north for X axis and bottom_top for Y axis
@ VAR Line plot using  bottom_top for the horizontal axis
@ VAR_SSO
© VEGFRA Cancel  (JCREEED)
ow
@ x esized GeoX coord te om D D
@ x_stag synthesized GeoX coordinate from D... 1D
@ XICEM XICEM Geo2D
@ XLAND XLAND Geo2D
© XLAT XLAT Geo2D
@ XLAT_U XLAT U Geo2D
@ XLAT_V XLAT V Geo2D
@ XLONG XLONG Geo2D
@ XLONG_U XLONG U Geo2D
@ XLONG_V XLONG V Geo2D
@ XTIME XTIME -
Qy synthesized GeoY coordinate from D... 1D
@ y_stag synthesized GeoY coordinate from D... 1D
Show: Allvariables (2]

e Seclect U in the variable list (3D U-wind), and create a “Color contour plot
using...” —> but change set the X axis as “south north” and Y axis as
“bottom_top”



Plot Controls

S Show: Arrays
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Plot  Array 10nly — [ Interpolate —

Uin wrfout_d01_2018-12-20_23:00:00

Datas|
| YArrayl:U
Synthesized time coordinate from Times(time): 1 of 1= 2018-12-2023:00:00 @
West_east_stag: 25 of 121 = 25 U
{ [> Array 2 . . - . - . . - . . . . . . . .
— =
QTS0 LY P’T | T —
© TKE_PBL TKE PBL
QTP TLP
© TLP_STRAT TLP STRAT 315
9 TMN TMN
Q TSK TSK
© TSK_FORCE TSK FORCE
© TSK_FORCE_TEND TSK FORCE T| Q235
@ TSLB TSLB 9
Qu u EI
Q u10 u10 o
© UDROFF UDROFF o
@ UsT usT Q155
oV \%
Q V10 V10
@ VAR VAR ‘
@ VAR_SSO VAR SSO
© VEGFRA VEGFRA
ow w
9 x synthesized
@ x_stag synthesized ) — el W,
@ XICEM XICEM -0.5 23.5 47.5 715 95.5 119.5
@ XLAND XLAND south_north
@ XLAT XLAT
@ XLAT_U XLAT U U(ms-1)
o Xty ry «4EENT .
@ JLONG XLoNg -8.0 4.8 17.6 30.5 433 56.2
@ XLONG_U XLONG U

e We now get a color-filled contour of U along a vertical slice, across latitudes

e We can choose the longitudinal position of our slice by choosing “Arrays” in
Plot Controls, and incrementing (or selecting) “West east stag”



