IDV Instructions for WRFV4

Updated: January 2023

Preliminaries

e Ensure that you've downloaded the required sample wrfout files to your

laptop

O
O
O

(@)

mkdir wrfouts_original
cd wrfouts_original
scp
username@optimum.eos.ubc.ca:/data/rstull/shared/ATSC50
7/WRF/wrfout_dol 2018-12-20* .

= All on one line
scp
username@optimum.eos.ubc.ca:/data/rstull/shared/ATSC50
7/WRF/wrfout_dol 2018-12-21%* .

= All on one line

Total: 2.8 GB

¢ Download IDV and install onto your computer

(@)

https://www.unidata.ucar.edu/downloads/idv/current/index.jsp




IDV Basics

e When you first open up IDV, you should see two windows pop up:

@ @ Unidata IDV - Map View - One Pane
File Edit Displays Data Bundles Tools Help
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2@ Maps
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| 18:54:19 GMT [Latitude: 57.9 Longitude: -30.4 Altitude: 0.0 m [

e This is the Map View, and will show the bulk of the plots you make



File Edit Displays Data Bundles Tools Help

wE oEHEY e 24 SO @8
R Quicklinks 4 Data Choosers [ Field Selector Displays

E@Viewl File Edit View Help

Default Background Ma. b z2<  lat/Lon
L]
E Maps
World Country Outlines 10 ¢ ____ ¢ Fast rendering = @ B
v/ World Coastlines 1.0 ¢ ___ ¢ - Fast rendering * [d (&
World Political Boundaries 1.0 ¢ _._._ ¢ - Fast rendering * [ (&
North & Central America 1.0 ¢ ___ ¢ - Fast rendering % B
Hi-Res US 1.0 ¢ ¢ - Fast rendering ¥ )
U.S. County Outlines 0 __ ¢ - V| Fast rendering = &
Position: -0.99
Bottom Middle Top

yEHMO G

[ 18:54:26 GMT |

e This is the Dashboard. This window provides most of the settings for the
plots you’d make in the Map View
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e The black background isn’t that great to work with, so let’s give the Map View
a white ocean background
o “View” > “Color” > “Blue on white”



Dashboard

File Edit Displays Data Bundles Tools Help
» DHEBY e 24 SO @
R Quicklinks [ Field Selector Displays
<
v -
Gen " Data Source Type: I'm Feeling Lucky
URLs _—
Catalogs [ wrfouts_original
v sat Z"::;ery Name ~  Date Modified
Images wrfout_d01_2018-12-20_00/00/00 Tuesday, December 17, 2019 4:51 PM
wrfout_d01_2018-12-20_01/00/00 Tuesday, December 17, 2019 4:51 PM
Gm wrfout_d01_2018-12-20_02/00/00 Tuesday, December 17, 2019 4:51 PM
Radar wrfout_d01_2018-12-20_03/00/00 Tuesday, December 17, 2019 4:51 PM
¥ Observations wrfout_d01_2018-12-20_04/00/00 Tuesday, December 17, 2019 4:51 PM
Point wrfout_d01_2018-12-20_05/00/00 Tuesday, December 17, 2019 4:51 PM
RAOB wrfout_d01_2018-12-20_06/00/00 Tuesday, December 17, 2019 4:52 PM
Fronts wrfout_d01_2018-12-20_07/00/00 Tuesday, December 17, 2019 4:52 PM
wrfout_d01_2018-12-20_08/00/00 Tuesday, December 17, 2019 4:52 PM
wrfout_d01_2018-12-20_09/00/00 Tuesday, December 17, 2019 4:52 PM
wrfout_d01_2018-12-20_10/00/00 Tuesday, December 17, 2019 4:52 PM
wrfout_d01_2018-12-20_11/00/00 Tuesday, December 17, 2019 4:52 PM
wrfout_d01_2018-12-20_12/00/00 Tuesday, December 17, 2019 4:52 PM
wrfout_d01_2018-12-20_13/00/00 Tuesday, December 17, 2019 4:52 PM
wrfout_d01_2018-12-20_14/00/00 Tuesday, December 17, 2019 4:52 PM
wrfout_d01_2018-12-20_15/00/00 Tuesday, December 17, 2019 4:52 PM
wrfout_d01_2018-12-20_16/00/00 Tuesday, December 17, 2019 4:52 PM
wrfout_d01_2018-12-20_17/00/00 Tuesday, December 17, 2019 4:53 PM
wrfout_d01_2018-12-20_18/00/00 Tuesday, December 17, 2019 4:53 PM
wrfout_d01_2018-12-20_19/00/00 Tuesday, December 17, 2019 4:53 PM
wrfout_d01_2018-12-20_20/00/00 Tuesday, December 17, 2019 4:53 PM
File Format:  All Files
Please select a file
Add Source @ @
[ 18:57:48 GMT |

e Now on the dash board, click “Data Choosers”

e Navigate to where your wrfout files are stored, and click on the file
wrfout_d01_2018-12-21_00:00:00

e C(lick “Add Source”, and hit OK when prompted



[ JOX ) Dashboard
File Edit Displays Data Bundles Tools Help

wE oEHeEwY oM 24 SO @8
2 Quicklinks 4 Data Choosers Bl JNAGELEEEaGias & Displays

Data Sources: Fields @, Displays
Formulas v 2D grid
b .../wrfout_d01_2018-12 ¥ Derived

fix) Absolute Vorticity (from U10 & V10)
fix) Flow Vectors (from U10 & V10)
Horizontal Advection (from U10 & V10)
f(x) Horizontal Divergence (from U10 & V10)
ftx) Horizontal Flux Divergence (from U10 & V10)
fix) Relative Vorticity (from U10 & V10)

ftx) Speed (from U10 & V10)

Jix) True Wind vectors (from U10 & V10)
& -
<7 ACCUMULATED DOWNWELLING CLEAR SKY LONGWA\
<7 ACCUMULATED DOWNWELLING CLEAR SKY LONGWA\
<7 ACCUMULATED DOWNWELLING CLEAR SKY SHORTWA
<7 ACCUMULATED DOWNWELLING CLEAR SKY SHORTWA
<7 ACCUMULATED DOWNWELLING LONGWAVE FLUX AT
<7 ACCUMULATED DOWNWELLING LONGWAVE FLUX AT
<7 ACCUMULATED DOWNWELLING SHORTWAVE FLUX AT
<7 ACCUMULATED DOWNWELLING SHORTWAVE FLUX AT
<7 ACCUMULATED GROUND HEAT FLUX
<7 ACCUMULATED MELTED SNOW
<7 ACCUMULATED SHALLOW CUMULUS PRECIPITATION
<7 ACCUMULATED TOTAL CUMULUS PRECIPITATION
<7 ACCUMULATED TOTAL GRID SCALE GRAUPEL
<7 ACCUMULATED TOTAL GRID SCALE HAIL
<7 ACCUMULATED TOTAL GRID SCALE PRECIPITATION
<7 ACCUMULATED TOTAL GRID SCALE SNOW AND ICE
<7 ACCUMULATED UPWARD HEAT FLUX AT THE SURFAC
<7 ACCUMULATED UPWARD LATENT HEAT FLUX AT THE
£7 ACCUMUILATED HPWFILING C1FAR SKY | ONCGWAVF FI

Create Display

[ 18:58:18 GMT |
¢ You should then be taken to the “Field Selector” tab. You will see 2D grid and
3D grid as options

e C(lick the arrow next to 2D grid. You will see a whole bunch of raw 2D fields
available, as well another arrow for Derived fields



TN ) Dashboard
File Edit Displays Data Bundles Tools Help

wnE oEHEBY e 24 SO @8
2 Quicklinks 4 Data Choosers [ INAELEEEaGiad S Displays

Data Sources: Fields &, Displays
Formulas PBL HEKﬂj‘T ) _ v Imagery
» .../wrfout_d01_2018-12 perturbation dry air mass in column Image Display

Scatter Display
PHYSICAL SNOW DEPTH ¥ Plan Views

POT TEMP at 2 M Contour Plan View

Qvat2 M Color-Filled Contour Plan View
<7 RESIDUAL OF THE NOAH SURFACE ENERGY BUDGET Color-Shaded Plan View

<7 SEA ICE FLAG

g
o
£7 perturbation dry air mass in column
&
&

N

Value Plots
£ SEA ICE FLAG (PREVIOUS STEP)
£ SEA SURFACE TEMPERATURE Region  Data Sampling
£ SEA SURFACE TEMPERATURE FROM WRFLOWINPUT Fl
£ SFC PRESSURE Use Default
2 SKIN SEA SURFACE TEWPERATURE P

<7 SNOW WATER EQUIVALENT
<7 SOIL TEMPERATURE AT LOWER BOUNDARY
<7 SURFACE EMISSIVITY
<7 SURFACE RUNOFF
<7 SURFACE SKIN TEMPERATURE
z
<7 Terrain Height
<7 TOA OUTGOING LONG WAVE
< UatloM
<7 U* IN SIMILARITY THEORY
<7 UNDERGROUND RUNOFF
<7 UPWARD HEAT FLUX AT THE SURFACE
<7 UPWARD MOISTURE FLUX AT THE SURFACE
< VatloM
<7 variance of subgrid-scale orography
<7 VEGETATION FRACTION
» 3D grid

Create Display

[ 19:00:22 GMT |

e Let's start simple with 2-m temperature. Click “TEMP at 2 M”, then under
“Plan Views” choose “Color-Filled Contour Plan View”

e At the bottom, click “Create Display”



File Edit Displays Data Bundles Tools Help

wE oEHBY o8 24 @ @8
2 Quicklinks 4" Data Choosers [ Field Selector Displays

E@Viewl File Edit View Help

Default Background Maps Contour: Change Interval: 1 celsius
T2 - Color-Filled Conto. k

Color Table: Temperature -2 1 B2 celsius

Vertical Position: ' @ [ ) Contour Properties Editor
Bottom Middle Contour Interval: |1 celsius
Smoothing: None C| Factor: |6

1 Base Contour: 0 celsius
~ M = . . F
L0 G Minimum Value: -32 celsius —

Maximum Value: 32 celsius

Line Width: 1 C

Dash: I <

Labels:

Font: Default

Size: 12

oo

Align:  Along Contours

Frequency: I
Lo Med Hi

Label Every Nth Line: 2|1

Apply OK Cancel
——

[ 19:02:34 GMT | [
¢ Youshould see a plot created in Map View, but we can make it a whole lot
nicer

e On your Dashboard, under the “Displays” tab, “Change” the contour settings
with the same settings as what you see above

e For “Temperature” next to “Color Table”, change the range from -32 and 32,
as seen above
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e Your Map View should now look something like this, with much finer

contours than before

e Note that the plot is rotated from the map we saw from the beginning; that’s
because we’re plotting using the domain’s projection (polar stereographic)




| File Edit Displays Data

Dashboard

Bundles Tools Help

Data Sources:
Formulas

»E oHEBY o8 24 S@ @8

R Quicklinks 4 Data Choosers BINFECRE el B Displays

}.../wrfout_d01_2018-12

Fields @&, Displays
v 2D grid ¥ Flow Displays
Vv Derived [Vector Plan View

fix) Absolute Vorticity (from U10 & V10)

fix! Flow Vectors (from U10 & V10)

f(x) Horizontal Advection (from U10 & V10)

7%} Horizontal Divergence (from U10 & V10)

fix) Horizontal Flux Divergence (from U10 & V10)

fi%) Relative Vorticity (from U10 & V10)

fix) Speed (from U10 & V10)

B True Wind vectors (from U10 & V10)|
& -
<7 ACCUMULATED DOWNWELLING CLEAR SKY LONGWA\
<7 ACCUMULATED DOWNWELLING CLEAR SKY LONGWA\
<7 ACCUMULATED DOWNWELLING CLEAR SKY SHORTWA
<7 ACCUMULATED DOWNWELLING CLEAR SKY SHORTWA
<7 ACCUMULATED DOWNWELLING LONGWAVE FLUX AT
<7 ACCUMULATED DOWNWELLING LONGWAVE FLUX AT
<7 ACCUMULATED DOWNWELLING SHORTWAVE FLUX AT
<7 ACCUMULATED DOWNWELLING SHORTWAVE FLUX AT
<7 ACCUMULATED GROUND HEAT FLUX
<7 ACCUMULATED MELTED SNOW
<7 ACCUMULATED SHALLOW CUMULUS PRECIPITATION
<7 ACCUMULATED TOTAL CUMULUS PRECIPITATION
<7 ACCUMULATED TOTAL GRID SCALE GRAUPEL
<7 ACCUMULATED TOTAL GRID SCALE HAIL
<7 ACCUMULATED TOTAL GRID SCALE PRECIPITATION
<7 ACCUMULATED TOTAL GRID SCALE SNOW AND ICE
<7 ACCUMULATED UPWARD HEAT FLUX AT THE SURFAC
<7 ACCUMULATED UPWARD LATENT HEAT FLUX AT THE
&7 ACCIIMIUILATED LIPWFIHING C1FAR SKY I ONCWAVF FI

>

Vector Colored by Speed

Vector Colored by Another Parameter

Wind Barb Plan View
Wind Barb Colored by Speed

Wind Barb Colored by Another Parameter

> Flow Cross Section

Data Sampling

Use Default

[0}

Create Display

[ 19:10:20 GMT |

e Now let's add some wind vectors to the plot

e Under “Field Selector” on your Dashboard, click the arrow next to “Derived”,
and choose “True Wind vectors (from U10 & V10)”

e Choose “Vector Plan View”, and then “Create Display”

10



File Edit Displays Data Bundles Tools Help

»0 DHBY 98 24 @ @8
2 Quicklinks 4" Data Choosers [ Field Selector Displays

E@Viewl File Edit View Help

Default Background Maps e Vectors:
T2 - Color-Filled Conto.

= Size: 5.0 o Autosize
truewindvectors - Vect. ’

Streamlines:
Density: Low High
Sl Trajectories
Trajecotry Form: Line Length Offset: |4 o Arrow
Curly Vectors

Vector Length: |2 o

Arrow Scale: 1 o
Skip:  XY: 4.0 o

Range: -25.4to25.4 B/

Vertical Position:
Bottom Middle Top

<>

Color: red

Line Width: 2.0 = 2]

y@MO 6

[ 19:12:03 G™T| \

e The vectors in Map View should be barely visible. We can fix that under the

“Displays” tab on your Dashboard

e Firstly, we don’t need one vector for each grid point, that’s just too much.
Next to “Skip”, change “XY:” to 4.0

o This plots one vector for every 4t grid point
e We can make the vectors bigger by changing “Size:” to 5.0
e ..and make the arrows thicker by changing “Line Width:” to 2.0

e Finally, let’s change the “Color” of the arrows to red

¢ Your vectors should now show up much nicer on the Map View, but let’s plot

one final thing before seeing it again

11



File Edit Displays Data Bundles Tools Help
»E oHEY oM 24 SO @8
D Quicklinks 4P Data Choosers ~ [J == s::cco- B Displays
Data Sources: Fields @, Displays
» Formulas > Maps 3 Color (RGB) Image
.../wrfout_d01_2018-12  » Grids 3 Color (RGB) Image over topography
> Miscellaneous ¥ Plan Views
> Export Contour Plan View
> Imagery Color-Filled Contour Plan View
7%} Calculate hourly rainfall Color-Shaded Plan View
fix) Calculate hourly rainfall true Value Plots
kit Compute MSLP using barometric formula » Radar Displays
fix) Layered pressure >
Fix) testfunc [ ) [ ) Field Selector
Field: PSFC Field: HGT
> Formulas > Formulas
¥ /Users/tchui/wrfouts_origi ¥ /Users/tchui/wrfouts_origil
| ¥ 2D arid ¥ 2N arid
T Times >
Use Default a Use Default a
2018-12-21 00:00:00Z 2018-12-21 00:00:00Z2
Create
oK Cancel
[ 19:12:48 GMT |

e We want to plot MSLP, but MSLP is not a raw model field, nor is it

automatically derived in IDV

o ** The workflow to compute MSLP is different depending on your IDV

version***

COMPUTE MSLP - OLDER VERSIONS OF IDV

e On the very left of your Dashboard, you should see a “Formulas” tab. Click it,

and look under the “Imagery” option in the “

Fields” panel

¢ You should see “Compute MSLP using barometric formula”. This is an
example formula that IDV has pre-made. You can create your own Formula to
derive your own variables (we’ll do this with precipitation later).

e Choose it, then choose “Contour Plan View”.

e “Create Display”, then hit “OK” for all options. You will notice that you're
deriving MSLP from PSFC (surface pressure) and HGT (terrain height)

12




[ J Dashboard

»E DEHBY o8 24 SO @8

2 Quicklinks | 4 Data Choosers [ == - <= --.-- [ Displays
Data Sources: Fields @, Displays
» Formulas /%1 Grid 3D Trajectory (from %N1% & %N2% & %N3%) < Imagery
Jwrfout_d01_2018-12 ) Horizontal Advection (from %N1% & %N2%) aeIBicnlay

Horizontal Flux Divergence (from %N1% & %N2%)
ftx) Layer Difference

Scatter Display

Image Display Over Topograph
fix) Layer Wind Shear Image As 'T'o:ography pograpiy
fix) Make flow vectors from direction data Image Sequence Display

Fix) Make flow vectors from grid relative u and v data
#z) Make flow vectors from u and v data 3 Color (RGB). Image
RGB Composite

fix) Make flow vectors from u, v, and w data I
ftx) Make slice 2D
fix) One value colored by another
fix) Resample grid
f(x) Simple time difference in one parameter
fix) Slice at Altitude
Slice at Level B
) Speed from 2 components
Time step precipitation accumulation
f(x) Wind Shear Vectors
> Satellite
v Miscellaneous

fix) Any Field

ftx) Change Unit

Edit Formula
Copy Formula
Evaluate Formula
Evaluate and Save
Export to Plugin

time grids/imag

> Export
> Imagery

Create Display

| 19:11:56 GMT | |

[ ] Formula Editor

Description: mslp

Name: mslp

Formula:  PSFC/exp(-HGT/7290)/1000 bl 4
Advanced 2
Derived
Group: Miscellaneous
Displays: © Use all Use selected:
All on Imagery
All off Plan Views
Radar Displays
Vertical Cross Sections
Cross Sections
Trajectory
Change Formula Cancel Help

COMPUTING MSLP - NEWER VERSIONS OF IDV (6.0+)

e On the very left of your Dashboard, you should see a “Formulas” tab. Click it,
and look under the “Miscellaneous” option in the “Fields” panel

¢ You should see “Define a formula.” Right-click, and choose “Copy Formula.”

13



In the Formula Editor, change the Description and Name fields to “mslp.”
Then, insert the formula into the Formula box as follows:

o PSFC/exp(-HGT/7290)/1000
o This will compute the mean sea level pressure in kPa, assuming a dry
and isothermal atmosphere

Click “Change Formula”.

Now choose “mslp” in the Fields panel (under “Miscellaneous”), then choose
“Contour Plan View”.

“Create Display”, then hit “OK” for all options. You will notice that you're
deriving MSLP from PSFC (surface pressure) and HGT (terrain height)

14



( JoX J
File Edit Displays Data Bundles

Dashboard

Tools Help

»E oHEBY o8 24 SO @8
2 Quicklinks 4 Data Choosers [ Field Selector

E@Viewl File Edit View Help

Default Background Maps Contour:
T2 - Color-Filled Conto.
truewindvectors - Vector. Color Table:

MSLP - Contour Plan Vi. }

Vertical Position:

Smoothing:

*HO0 G

Change Interval: .5

Black  97.4 103 4

Edit Color Table
Change Range...

Use Default Middle e
Factor: 6 o
Transparency » |
Dimmer
Basic >
Radar >
Satellite >
Misc. »
I Back
— White
Yellow
Cyan
I Red
I Blue
[ Gray
[ Green
[N Magenta
Orange
Pink

[ 19:14:06 GMT |

e Again, the default plot will look ugly and be barely visible

e Under the “Displays” tab, change the contour interview to 0.5

e Under “Color Table”, choose “Solid” > “Black”

o This enforces a single color for all contours; better, since temperature
is already color-filled contours
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File Edit Displays Data Bundles Tools Help
nE oEHEBY e 24 F/@ @8
2 Quicklinks 4 Data Choosers [ Field Selector & ~<- -

E@Viewl File |Edit| View Help

- Default Background Ma. Contour: Change Interval: 1 celsius
T2 - Color-Filled Conto. ¥
truewindvectors - Vector. Color Table: Temperature 32N 0 32 celsius
IMSCEEContoudblaniview] [ BON J Properties -- T2 - Color-Filled Contour Plan View
Vertical Position: a Settings [MEdllal Times  Spatial Subset
\ -
Smoothing: Visible:
— & Position: Top a
MEMO 6
Labels: Visible
Show Unit
Font: = Default E Bold a 15 E

Color: - Change

Apply OK Cancel

[ 119:39:22 GMT |

e Before we finalize our plot, let’s add a colorbar for our temperature contours
as well

e On the left, under “View 1”, choose “T2 - Color-Filled Contour”

e C(lick the “Edit” button marked by the red box in the image above, and choose
“Properties”

e C(lick the “Color Scale” tab. Check “Visible” and “Show Unit”. Change the
Position to “Top”

¢ Change the font color to black, make it bold, and increase its font size to 15

16



[ XON | Dashboard
File Edit Displays Data Bundles Tools Help

O oEHEBY o8 24 /@ @8
R Quicklinks 4 Data Choosers [ Field Selector JEIRRIIENS

E@Viewl File Edit View Help

Default Background Ma. b m Lat/Lon
T2 - Color-Filled Conto.
truewindvectors - Vector.

B Maps
MSLP - Contour Plan View —

World Country Outlines w0 ¢ B Fast rendering + &

® World Coastlines 1wl ([— B - Fast rendering % )
World Political Boundaries 1.0 ¢ e a - Fast rendering ¥ [ (&
North & Central America 0 B - Fast rendering ¥ [ &
Hi-Res US 1.0 ¢ N a - Fast rendering ¥ [ (&
U.S. County Outlines 1.0 ¢ — B - Fast rendering ¥ [ &

Position: -0.99

Bottom Middle Top
*EMO 6

[19:17:57 amT |

e One last thing: because the coastline colors are green by default, it makes the
continent difficult to see underneath the temperature contours

e In the “Displays” tab, choose “Default Background Map” on the left under
“View 1”

e For the color box next to “World Coastlines”, change to black

17



[ XON ) Unidata IDV - Map View - One Pane
File Edit Displays Data Bundles Tools Help

»O oEHBY o8 24 7@ @0
= <
— » Legend
View  Projections » 2018-12-21 00:00:00Z RTINS 5 as g
2 @ _- Default Background ... & f

-32 =22 b celsius World Coastlines

|

= Plan Views
B @ MSLP - Contour Plan Vied 5 £

©BORNGEER

974 1034

= @ T2 - Color-Filled Conto.} 5

| |
-32 32

B Flow Displays
B @ truewindvectors - Vect. .} 5

Color: [l T

NU «=11DPL

Do

.......

------

MSLP - Contour Plon View
T2 - Cnlor Filled Contour Plon

[ 19:50:33 GMT [Latitude: 70.6 Lonaitude: ~163.8 Altitude: 0.0 m

e And there you have it! A plot of MSLP, 2-m temperature and 10-m wind
vectors all on one panel, with a temperature colorbar placed at the top. Not
the prettiest plot in the world, but it works.

e Congrats on making your first 2D contour plot in IDV!

e Feel free to make this plot with other times as well, or explore other 2D
fields.

e Once you're done, you can click the trash cans highlighted by the red boxes
above to get rid of the layers; keep the Default Background map

18



Formula Editor
Description: | Calculate hourly rainfall true

Name: Hourly rain

Formula:  RAINNC +RAINC + RAINSH - (RAINNC1 + RAINC1 + RAINSH1) B

Advanced #

Group: <

Displays: @ Use all Use selected:

All on

E E

All off

HE EE

]

e Now, we want create an accumulated precipitation plot.

e Precipitation in wrfout files is accumulated from the very first wrfout file;
hence, to plot hourly or 3-hourly or 6-hourly precipitation, we need to do
some simple subtraction

e Precipitation is also divided into three main variables: RAINNC (grid-scale
precipitation, computed from the microphysics scheme), RAINC (cumulus
precipitation, computed from the cumulus scheme), RAINSH (shallow
cumulus precipitation, computed from the shallow cumulus scheme, if
applicable)

o Accumulated precipitation between current time and some previous
time = (RAINNC + RAINC + RAINSH)current time — (RAINNC + RAINC +
RAINSH)previous time

o None of our files should have a shallow cumulus scheme turned on, so

RAINSH should be uniformly 0, but we’ll pretend that it's on anyway
for our calculations

¢ Onyour Dashboard, go back to “Field Selector” > “Formulas”

Right-click on “Calculate hourly rainfall” (OLDER VERSIONS OF IDV)/"Define a
formula” (NEWER VERSIONS OF IDV) and choose “Copy Formula”

o “Calculate hourly rainfall” does add up RAINNC + RAINC + RAINSH,
but does not subtract from some previous time; hence, it's actually the
total accumulated precipitation up to that point

o We need to do the subtraction ourselves

e Change the Description and Formula to what you see in the image above
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o Formula = RAINNC + RAINC + RAINSH - (RAINNC1 + RAINC1 +

RAINSH1)

File Edit Displays Data Bundles Tools Help

plays Data Bundles Tools Help

»Q oHaY o8 24 /@ @8
2 Quicklinks 4 Data Choosers (3 ~ - - O Displays

Data Sources: Fields @ Displays

» Formulas » Maps 3 Color (RGB) Image over topography

../wrfout_d01_2018-12  » Grids ¥ Plan Views

./wifout_d01_2018-12 > Miscellaneous Contour Plan View
- o [Color-Filled Contour Plan View]

> Imagery Color-Shaded Plan View

/) Caleulate hourly rainfall Value Plots

8lCalcuiate hourly rainfall true » Radar Displays
71z Compute MSLP using barometric formula ¥ Vertical Cross Sections
71 Layered pressure »

Field: RAINNC

Field: RAINC

27 ACCUMULATED DOWNWELLING CLEAR SKY
&7 ACCUMULATED DOWNWELLING CLEAR SKY
&7 ACCUMULATED DOWNWELLING CLEAR SKY
£ ACCUMULATED DOWNWELLING CLEAR SKY
&7 ACCUMULATED DOWNWELLING LONGWAVE
&7 ACCUMULATED DOWNWELLING LONGWAVE
£ ACCUMULATED DOWNWELLING SHORTWAY
&7 ACCUMULATED DOWNWELLING SHORTWAV
27 ACCUMULATED GROUND HEAT FLUX

£ ACCUMULATED MELTED SNOW

&7 ACCUMULATED SHALLOW CUMULUS PRECIP
27 ACCUMULATED TOTAL CUMULUS PRECIPIT/
&7 ACCUMULATED TOTAL GRID SCALE GRAUP
&7 ACCUMULATED TOTAL GRID SCALE HAIL

g JLATED TOTAL GRID SCALE PRECIP|

/7 ACCHMILATEN TATAL CRIN SEAIF SNOW

£7 ACCUMULATED DOWNWELLING CLEAR ¢
£ ACCUMULATED DOWNWELLING CLEAR ¢
&7 ACCUMULATED DOWNWELLING CLEAR ¢
£7 ACCUMULATED DOWNWELLING CLEAR ¢
&7 ACCUMULATED DOWNWELLING LONGW.
&7 ACCUMULATED DOWNWELLING LONGW.
£ ACCUMULATED DOWNWELLING SHORTY
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e Go back to Data Choosers, and load out wrfout_d01_2018-12-
20_18:00:00, so that we can make a 6-hour accumulated precipitation

plot

e Now in Formulas, choose your newly created Formula “Calculate hourly
rainfall rate”, and select “Color-Filled Contour Plan View”

e Manually select the correct fields for the current time (wrfout_d01_2018-12-

21_00:00:00 > ACCUMULATED TOTAL GRID SCALE PRECIPITATION,

ACCUMULATED TOTAL CUMULUS PRECIPITATION, ACCUMULATED

SHALLOW CUMULUS PRECIPITATION) as well as for the previous time

(wrfout_d01_2018-12-20_18:00:00, same fields)
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[ JoX ) Dashboard
File Edit Displays Data Bundles Tools Help
»O oEHBY o8 24 @ @8
2 Quicklinks 4P Data Choosers [ Field Selector
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- Default Background Ma. Color Table > terval: .25 in
Hourly rain - Color-Fill. b
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Change Display Unit... - 1 I I 10 in

Change Contours... L

Vertil .
Sharing > Middle Top

&< Display Settings... Factor 6 —
@ Properties...

*HMOE

[ 20:01:42 GMT |

e The produced plot will look ugly, and have the wrong units. Change the units
on your Dashboard > Displays > Edit > Change Display unit, to mm
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File Edit Displays Data Bundles Tools Help
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E@Viewl File Edit View Help

- Default Background Ma. Contour: Change Interval: .2 mm
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Bottom Middle
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( ) @ Contour Properties Editor
Contour Interval: .2 mm
Base Contour: .1 mm
Minimum Value: .1 mm
Maximum Value: 30 mm
Line Width: 1 <
Dash - C
Labels:
Font:  Default B
Size: 12 a
Align:  Along Contours a
Frequency: 1 |
Lo Med Hi
Label Every Nth Line: 2([C
| Apply OK Cancel
—-_

e Also change the contour intervals and color table as seen above

e Instead of using the default color table, choose Basic > Precip

¢ Finally, add in the MSLP contours we saw in the previous finished plot (do
the same as you did before), and add in a colorbar for the accumulated

precipitation plot

o You can change the label name from “Hourly rain” or whatever to
something more appropriate like “6-hr acc. precip” under “Edit” >
“Properties”, in the same window that you toggled colorbar options
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e ..and there you have it! Doesn’t look half bad! You can clearly make out the
frontal precip bands for the system contacting the coast.
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Data Sources:
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fix) Horizontal Advection (from U & V)
fix) Horizontal Divergence (from U & V)
ftx) Horizontal Flux Divergence (from U & V)
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Use Default

~
v

Create Display
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e One last thing, let’s add in a cross section of cloud water mixing ratio

e “Field Selector” > “3D grid” > “Cloud water mixing ratio”

e (Choose “Vertical Cross Sections” > “Color-Filled Contour Cross Section”
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File Edit Displays Data Bundles Tools Help
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You should see a transect show up in your Map View. The

+” corresponds to

the left side of your cross-section, the triangle the centre, and the square the

right
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e In the “Settings” tab under “Displays” on your Dashboard, change the contour
settings as shown above

e Also note that the vertical scale has been changed to 0 to 8000 m
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e If done correctly, under the “Display” tab on your Dashboard, you should see
a cross-section that looks something like what you see here

e Note the deep, cloudy air next to the square (right side of transect),
corresponding to the cold front of the storm

e Feel free to play around with the transect, by moving it around, lengthening
it, rotating it, etc.
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